IPv6 with prefix delegation and VRFs

Written in the wee hours in English • Tags: , ,

DNA Welho has added IPv6 support to all their cable hookups on June 9th,1 which was a national IPv6 deployment flag day in Finland. I only heard about it from Facebook comments today. Until now I’ve had IPv6 disabled on the private VRF because my fast cable hookup only provided IPv4. Using IPv6 from the DSL hookup would have just slowed things down.

After some poking around I was able to get my VRF-separated home network connected using a delegated prefix.

!
! Add a route for the cable modem.
!
! The cable modem needs to be rebooted for IPv6 to start working.
! Thomson boxes can be rebooted from the scan parameter page.
!
! I was already redistributing RFC-1918 addresses between VRFs,
! so adding the route in just VRF cable was sufficient.
!
ip route vrf cable 192.168.100.1 255.255.255.255 Vlan6 192.168.100.1 250

!
! Enable IPv6 on the VRF, if not already enabled.
!
vrf definition cable
 address-family ipv6
 exit-address-family
!

!
! Configure autoconfig + dhcp + pd on cable interface.
! Turn off router advertisements (and redirects).
!
! Install the default route from autoconfig.
! This interface is already in VRF cable.
!
! Do NOT enable rapid-commit on the PD.
! It will result in an expired delegation.
!
interface Vlan6
 ipv6 address dhcp rapid-commit
 ipv6 address autoconfig default
 ipv6 enable
 ipv6 nd ra suppress all
 no ipv6 redirects
 ipv6 dhcp client pd cable
!

!
! Arrange for the default route in VRF private.
! Static is ok: we can't route the PD anywhere else.
! We already have more specific routes for other stuff.
!
ipv6 route vrf private ::/0 Vlan6 nexthop-vrf cable 250

!
! Use the PD to get an address on the LAN.
!
interface Vlan3
 ipv6 address cable ::1/64
 ipv6 enable
!

!
! Need to redistribute connected to BGP, since we don't
! know the PD part of the network.
!
route-map connected-to-bgp-v6 permit 10
 match interface Vlan3
!
router bgp 65111
 address-family ipv6 vrf private
  redistribute connected route-map connected-to-bgp-v6
 exit-address-family
!

! XXX: Need to get rid of this!
! It comes from the DHCPv6 information.
ip domain list bb.dnainternet.fi